IT ENGLISH BOARD

Why is this preventing me installing an MSI: The System Administrator has set policies to prevent this installation

Server
Author
author
Date
2019-07-03 14:01
Views
1683








I am trying to install an MSI on a Windows Server 2012 machine which is part of my lab domain. I am local and domain admin, but I seem to be prevented from installing this MSI.

For clarification, when attempting to install the git extension for visual studio (located here) logged in as a domain user that is part of the administrator group, I get the following error

enter image description here

The machine reporting the error is a Windows Server 2012.

I'm almost certain it must be some sort of group policy restriction? None will have been set, unless it's the default security level?

For clarification, I'd like to know what is preventing this MSI being installed by a domain admin?


Total Reply 7

  • 2019-07-03 14:01

    After spending time looking at group policy, as far as I could tell, there was nothing that was relevant. I then came across this post that suggest I try launching a command promt as an administrator and running

    msiexec /a install.msi
    This appeared to work, but ran very quickly - in fact it didn't. On a whim, I tried this inside the admin command prompt.

    msiexec /i install.msi
    which worked a treat.


  • 2019-07-03 14:02

    I've run into this behavior, where MSI installation is prevented with "The system administrator has set policies to prevent this installation" before. I believe it is due to default Windows Software Restriction policy and I've seen it on both Windows Server 2008 R2 and Windows Server 2012.

    There is probably a better GUI based way to alter the policy, but setting the following reg key as an admin on the machine does the trick:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "DisableMSI"=dword:00000000


  • 2019-07-03 14:02

    This is usually due to a Group Policy or a Local Policy disabling Windows Installer.

    Look on your Domain Controller if you have a GPO disabling "Windows Installer": Computer Configuration > Administrative Templates > Windows Components > Windows Installer > "Turn off Windows Installer".

    Verify that it is set to "Not configured" or "Disabled".

    If if you don't find it in your GPO's, look on the computer's local policies using gpedit.msc.

    Note: the fact that you are a domain admins doesn't matter. It all depends of the scope of the GPO.


    • 2019-07-03 14:04

      Verify that it is set to "Not configured" or "Disabled". That's not true. The default (Not Configured) is 1 which means managed only. msdn.microsoft.com/en-us/library/aa368304.aspx Disabled in terms of gpos means the policy will be disabled, so the reg key will be deleted and the default is used. Sound's strange but you have to choose Enabled and select Never in the dropdown box


  • 2019-07-03 14:05

    right-click -> run as administrator


  • 2019-07-03 14:05

    Neither the msiexec nor registry fixes worked for me (even after rebooting), but disabling User Account Control and rebooting did the trick.


  • 2019-07-03 14:06

    You have the option to turn off UAC via registry by changing the DWORD EnableLUA from 1 to 0 in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system. You will get a notification that a reboot is required. After the reboot, UAC is disabled.


Total 104
Number Title Author Date Votes Views
33
Remove Powered by WordPress in 3 Easy Steps (2)
author | 2019.07.05 | Votes 0 | Views 12628
author 2019.07.05 0 12628
32
Fix: The System Administrator Has Set Policies to Prevent This Installation
author | 2019.07.03 | Votes 0 | Views 1448
author 2019.07.03 0 1448
31
Why is this preventing me installing an MSI: The System Administrator has set policies to prevent this installation (7)
author | 2019.07.03 | Votes 0 | Views 1683
author 2019.07.03 0 1683
30
Child Themes
author | 2019.06.29 | Votes 0 | Views 1397
author 2019.06.29 0 1397
29
My computer is running slow, what steps can I do to fix it?
author | 2019.06.29 | Votes 0 | Views 1361
author 2019.06.29 0 1361
28
Nighthawk M1 port forwarding not working (8)
author | 2019.06.27 | Votes 0 | Views 3694
author 2019.06.27 0 3694
27
Plugged in, not charging problem, Windows 10
author | 2019.06.17 | Votes 0 | Views 1417
author 2019.06.17 0 1417
26
How to fix a Windows 10 laptop that's plugged in but not charging - Cnet
author | 2019.06.17 | Votes 0 | Views 1464
author 2019.06.17 0 1464
25
WordPress. How to hide time and date from the post page
author | 2019.06.10 | Votes 0 | Views 1444
author 2019.06.10 0 1444
24
How to Remove the Date from Your WordPress Posts
author | 2019.06.10 | Votes 0 | Views 1428
author 2019.06.10 0 1428
New