IT ENGLISH BOARD

Why is this preventing me installing an MSI: The System Administrator has set policies to prevent this installation

Server
Author
author
Date
2019-07-03 14:01
Views
2257








I am trying to install an MSI on a Windows Server 2012 machine which is part of my lab domain. I am local and domain admin, but I seem to be prevented from installing this MSI.

For clarification, when attempting to install the git extension for visual studio (located here) logged in as a domain user that is part of the administrator group, I get the following error

enter image description here

The machine reporting the error is a Windows Server 2012.

I'm almost certain it must be some sort of group policy restriction? None will have been set, unless it's the default security level?

For clarification, I'd like to know what is preventing this MSI being installed by a domain admin?


Total Reply 7

  • 2019-07-03 14:01

    After spending time looking at group policy, as far as I could tell, there was nothing that was relevant. I then came across this post that suggest I try launching a command promt as an administrator and running

    msiexec /a install.msi
    This appeared to work, but ran very quickly - in fact it didn't. On a whim, I tried this inside the admin command prompt.

    msiexec /i install.msi
    which worked a treat.


  • 2019-07-03 14:02

    I've run into this behavior, where MSI installation is prevented with "The system administrator has set policies to prevent this installation" before. I believe it is due to default Windows Software Restriction policy and I've seen it on both Windows Server 2008 R2 and Windows Server 2012.

    There is probably a better GUI based way to alter the policy, but setting the following reg key as an admin on the machine does the trick:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "DisableMSI"=dword:00000000


  • 2019-07-03 14:02

    This is usually due to a Group Policy or a Local Policy disabling Windows Installer.

    Look on your Domain Controller if you have a GPO disabling "Windows Installer": Computer Configuration > Administrative Templates > Windows Components > Windows Installer > "Turn off Windows Installer".

    Verify that it is set to "Not configured" or "Disabled".

    If if you don't find it in your GPO's, look on the computer's local policies using gpedit.msc.

    Note: the fact that you are a domain admins doesn't matter. It all depends of the scope of the GPO.


    • 2019-07-03 14:04

      Verify that it is set to "Not configured" or "Disabled". That's not true. The default (Not Configured) is 1 which means managed only. msdn.microsoft.com/en-us/library/aa368304.aspx Disabled in terms of gpos means the policy will be disabled, so the reg key will be deleted and the default is used. Sound's strange but you have to choose Enabled and select Never in the dropdown box


  • 2019-07-03 14:05

    right-click -> run as administrator


  • 2019-07-03 14:05

    Neither the msiexec nor registry fixes worked for me (even after rebooting), but disabling User Account Control and rebooting did the trick.


  • 2019-07-03 14:06

    You have the option to turn off UAC via registry by changing the DWORD EnableLUA from 1 to 0 in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system. You will get a notification that a reboot is required. After the reboot, UAC is disabled.


Total 104
Number Title Author Date Votes Views
103
Join a Microsoft Teams meeting
author | 2020.09.22 | Votes 0 | Views 3175
author 2020.09.22 0 3175
102
How to delete songs and albums from your Google Play Music library
author | 2020.09.19 | Votes 0 | Views 3349
author 2020.09.19 0 3349
101
Watch Prime Video on Chromecast
author | 2020.09.14 | Votes 0 | Views 3353
author 2020.09.14 0 3353
100
How to Fix the Win­dows 10 We Could­n’t Con­nect to the Update Ser­vice Issue (2)
author | 2020.09.09 | Votes 0 | Views 4159
author 2020.09.09 0 4159
99
IONOS Joomla! Standard Installation
author | 2020.09.02 | Votes 0 | Views 2100
author 2020.09.02 0 2100
98
How to improve the life of a Battery: (1)
author | 2020.08.25 | Votes 0 | Views 2135
author 2020.08.25 0 2135
97
Laptop battery not charging
author | 2020.08.21 | Votes 0 | Views 2440
author 2020.08.21 0 2440
96
Plugged in, not charging (1)
author | 2020.08.21 | Votes 0 | Views 2250
author 2020.08.21 0 2250
95
How to add reCaptcha plugin to a custom form on my WordPress website?
author | 2020.08.13 | Votes 0 | Views 2432
author 2020.08.13 0 2432
94
I can't log in to the WordPress admin dashboard after installing and activating Limit Attempts plugin
author | 2020.08.13 | Votes 0 | Views 2105
author 2020.08.13 0 2105
New