Nighthawk M1 port forwarding not working

2019-06-27 15:34

Nighthawk M1 port forwarding not working

Hi folks,

I have a Nighthawk M1 router on a Telstra Business plan with a telstra.extranet APN (public IP address).

I am trying to set up port forwarding for port 3000 to a device connected via a switch to the router.  It has a static IP address allocated to eth0 (192.168.x.x) and a DHCP address allocated to wlan0 (which is a link local address 169.254.x.x)

I can connect to the router config (on port 80) just fine but the port forwarding simply doesn't work.  The same IP with port 3000 refuses to connect.

I have followed the instructions in the Nighthawk M1 router manual and rebooted the router.

Still no dice.  Has someone at Telstra disabled a range of ports or otherwise prevented port forwarding to work?

Has anyone had a similar problem and solved it?

I have tried all recommendations.

Technical support had no idea what to do to fix my issue so i told them to add the code GPTEXB3 to my account.

The second time i called a lady helped me add a APN entry called Telstra.Extranet and that still didnt work.

I have enabled ports 21, 22 and 80 but according to port checking website all ports are still closed.

Im also suppose to have a static public IP but my public IP keeps changing.

Static Public IP Address are not possible on the Telstra Mobile Network.

The GPTEXB3 (Telstra Extranet) product provides a Dynamic Public IP only, which will change if your modem is restarted, or a new session is started for any reason.
Total Reply 8

  • 2019-06-27 15:40

    It would seem that we have been sold a pup with the Nighthawk M1. Refers as one case.

    Port forward cannot be made to work either with the base version with New IP every boot, or the business version with a fixed IP.

    So if we want to set up a home server and use No-IP for example, that's exactly what we finish up with --- NO IP contact back to the Nighthawk, no open ports, bleh!

    Tech support seems to be haphazard to non-existent, and the suggestion has been made to obtain GPTEXB3 to set a fixed IP. Well apparently that doesn't work because fixed address's aren't available on mobile wireless.

    Ok, that's my summation after hours of review, so unless someone can tell me different, and after after 54 years of pain from Telstra I will hope that another ISP can do better.

    Over to you.

  • 2019-06-27 15:42

    You will not get port forwarding to work on any Mobile Broadband Modem due to the carrier grade NAT. All Mobile Carriers use CGNAT.

    When you tested if the port was open was the IP address displayed on the open port checker web page the same as the external IP address of the Nighthawk MI?

  • 2019-06-27 16:38

    Port forwarding in 3G/4G
    Hi, a friend has a 3/4G router box you supplied for Wireless Broadband (they can't get DSL where they are - very poor) and they are trying to enable port forwarding so they can access security cam system from a remote loc.

    Box is made by Netcomm and has port forwarding ability, however this function seems not to work. IP address (according to is 1.x.x.x which I've never seen before, but seems to be Telstra according to a DNS lookup.

    However it's apparently NOT the IP of the Netcomm box, which seems to have a 10.x IP on the Telstra side, and a tracert doesn't reveal the 1.x.x.x IP anywhere. So I'm guessing despite the box being capable of port forwarding, the 3G/4G Telstra Wireless Broadband system is not.

    Can you confirm or advise what we are doing wrong, because I've done this many times with DSL routers and it worked fine.

    Please note this is not a DynDNS issue (though that is apparently broken by this as well,) but the raw IP address is not reachable despite setting up port forwarding to the appropriate inside IP addresses on the LAN they have.

    Any help appreciated.

  • 2019-06-27 16:40

    I'm no wiz when it comes to this stuff but I see you have had no reply and it's been longer than 4 hours.

    So I did some reserach and found this out for you:

    Public/static IP addresses are not available on a wireless service hence port forwarding is not avilable, this is only avilable to business customers.

    If you get a Bigpond Mobile Broadband service than you will have a public IP which will alow you to port foward.

    Hope this helps.

  • 2019-06-27 16:42

    Correct, with the exception of Business Customers, I think this is a product that is only offerred to Account Managed Customers, not any business customer can request it.

    Bigpond Mobile Broadband is defs the way to go!!

  • 2019-06-27 16:45

    Ahem, pardon? The difference between a WIRELESS service and a MOBILE BROADBAND service is what exactly? They are using 3G to connect to the internet from a Telstra supplied modem/router - there is NO DSL or anything else (other than POTS dialup) available where they are. To me, that's Mobile Broadband or Wireless Broadband - both really. It just depends whether its a fixed installation or moving around near as I can see.

    A static IP is not required for port forwarding,. DynDNS works with static or dynamic IPs, or you can just find you IP address at the time and use that (awkward but doable). My question was whether it supports port forwarding. If not, why the heck not? I've no doubt my friends told Telstra what they wanted it for (to view the security cameras at their worksite from their home) so one would expect that it would be capable of that.

    They were with Cirrus Wireless (their home still is) but the coverage sucks and it was subject to constant dropouts. The Wireless/Mobile Broadband works well (though they need an expensive Yagi to get it from Gladstone's tower) and is more reliable.

    If this simple minded system doesn't have a public IP, that would have been good to know BEFORE they paid a small fortune to get it connected. (I did mention the yagi is expensive, right?)

    Hope this helps.

    Not really. You seem to be telling me that Wireless Broadband and Mobile Broadband are two different things.

    They use a 3G (4G isn't available here AFAIK) connection from a Telstra supplied, Netcomm manufactured box to do so, yet port forwarding to the first public hittable IP seems to be internal to Telstra, so naturally it doesn't work. So what exactly do they have please and how do they get something actually useful?


  • 2019-06-27 16:52

    The answer is pretty simple, and has nothing to do with how you connect to the internet, rather the product that you have acquired.

    Bigpond Mobile Broadband comes with a Dynamic Public IP address. This is the sort of address that you can connect to from the outside world.

    Telstra Pre-Paid Mobile Broadband, or Telstra Mobile Broadband services are connected with a Private IP address (in the form 10.x.x.x) which then connects to the greater internet. What this means is that you are unable to use Port Forwarding or Dynamic DNS services with these 2 products (as you connect with the same IP address as several other customers). There are exceptions to this rule for customers with an Account Executive.

    It should be noted that neither products expressly state that you will be able to use DynDNS with them, and Telstra is therefore not required to support DynDNS or any equivalent.

    I've also referred to another device I have with a Telstra competitor, and again found that I have an Internal IP address for it. Its not uncommon for Mobile Devices to connect this way.

  • 2019-06-27 16:59

    So what's the solution?

    The solution is simple - Acquire a Bigpond Mobile Broadband service (or other service such as ADSL or dialup or satellite) that provides you with what you need.

    If you were expressly told the product they were offered would provide a dynamic public IP address, then I would seam a refund under the "Australian Consumer Law".

Total 104
Number Title Author Date Votes Views
Join a Microsoft Teams meeting
author | 2020.09.22 | Votes 0 | Views 2014
author 2020.09.22 0 2014
How to delete songs and albums from your Google Play Music library
author | 2020.09.19 | Votes 0 | Views 2183
author 2020.09.19 0 2183
Watch Prime Video on Chromecast
author | 2020.09.14 | Votes 0 | Views 1956
author 2020.09.14 0 1956
How to Fix the Win­dows 10 We Could­n’t Con­nect to the Update Ser­vice Issue (2)
author | 2020.09.09 | Votes 0 | Views 2682
author 2020.09.09 0 2682
IONOS Joomla! Standard Installation
author | 2020.09.02 | Votes 0 | Views 1157
author 2020.09.02 0 1157
How to improve the life of a Battery: (1)
author | 2020.08.25 | Votes 0 | Views 1171
author 2020.08.25 0 1171
Laptop battery not charging
author | 2020.08.21 | Votes 0 | Views 1479
author 2020.08.21 0 1479
Plugged in, not charging (1)
author | 2020.08.21 | Votes 0 | Views 1295
author 2020.08.21 0 1295
How to add reCaptcha plugin to a custom form on my WordPress website?
author | 2020.08.13 | Votes 0 | Views 1432
author 2020.08.13 0 1432
I can't log in to the WordPress admin dashboard after installing and activating Limit Attempts plugin
author | 2020.08.13 | Votes 0 | Views 1110
author 2020.08.13 0 1110